Follow us on Twitter!
Ideas are far more powerful than guns.
Wednesday, April 16, 2014
Navigation
Home
HellBoundHackers Main:
HellBoundHackers Find:
HellBoundHackers Information:
Learn
Communicate
Submit
Shop
Challenges
HellBoundHackers Exploit:
HellBoundHackers Programming:
HellBoundHackers Think:
HellBoundHackers Track:
HellBoundHackers Patch:
HellBoundHackers Other:
HellBoundHackers Need Help?
Other
Members Online
Total Online: 19
Guests Online: 15
Members Online: 4

Registered Members: 82810
Newest Member: TheDuke777
Latest Articles
View Thread

HellBound Hackers | Computer General | General Computer Problems

Author

Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 28-12-06 07:02
I just got a new laptop, and installed Ubuntu 6.10 on it to try to learn a new distro, but I'm having a few issues:

1.) How do I change the system-recognized network manager? There are so many better ones than the default one, but none of them have any effect on what network I use, they just make me put in the root password so they can tell me they can't connect, which I can do if I go the lengthier way of the default network manager.

2.) I'm trying to install the Nvidia GeForce Go drivers, and to do that I need to disable X somehow. I know how to reboot X, but aside crashing myself or shitting up my file system, I'm not sure how to get it off temporarily.

Help, please?


Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 28-12-06 07:14
Well, seeing how I just started downloading Ubuntu 6.10 like 40 minutes ago, I am guessing I will also need the help.


Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 28-12-06 07:35
@prometheus>

try to let dhcp aquire a network address?backtrack can do that Pfft

and to get rid of the GUI you have to boot @ a lower run-level.
i guess3and up will give you X...not sure how to lower it on ubuntu...
if@all possible...i always boot command prompt.just quit or exit X
should do the trick i guess.

i haven't ever installed ubuntu or anything,so these are kinda
wild guesses...hope it's of any use...

peace.




Edited by on 28-12-06 07:37
Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 28-12-06 08:43
Its not connecting that's the problem, its being locked in to the bitchy app.

Speaking of being locked in, I apparently voided my warranty by installing Ubuntu.

It says I need to be at runlevel 3 or higher when I boot into runlevel 1. So HOW exactly do I kill X?


Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 28-12-06 09:09
have you tried to boot from the live cd,as for the network problem?
to see if that works?

as for the other problem:

the one thing i can come up with is to
try to modify your X's config file or something...or disable it...
i guess it's somewhere around there: /etc/x11/
if you screw up,X just fails to start :ninja: so....
after that,config your graphix card,make sure you set the
resolution to minimum,else you'll probably have the problem,
of X not starting,just when you want it...
there are probably better ways to fix this,but i don't use
linux/unix that often...which i should Pfft

so...good luck with it...




Edited by on 28-12-06 09:17
Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 28-12-06 14:13
Prometheum wrote:
I just got a new laptop, and installed Ubuntu 6.10 on it to try to learn a new distro, but I'm having a few issues:

1.) How do I change the system-recognized network manager? There are so many better ones than the default one, but none of them have any effect on what network I use, they just make me put in the root password so they can tell me they can't connect, which I can do if I go the lengthier way of the default network manager.

2.) I'm trying to install the Nvidia GeForce Go drivers, and to do that I need to disable X somehow. I know how to reboot X, but aside crashing myself or shitting up my file system, I'm not sure how to get it off temporarily.

Help, please?


Yes, you void your warranty on a new laptop when you install Linux; using Partition Magic and dual-booting Linux, however, SHOULDN'T void your warranty.

As far as the network problems are concerned, I don't use the GUI to configure my ethernet connections anymore. Pop open a terminal and type "sudo ifconfig eth0 <address> broadcast <broadcast address> netmask <network mask... the one with 255's>" (without the <>Wink and hit Enter. Does it give you an error message? If not, try pinging your gateway; if that works fine, then type "route gw <gateway address>" and hit Enter. If you get any errors, post them so that we can see what problem you might be having. You might also want to check UbuntuForums.org ... they have a lot of FAQs.

You have two options when stopping X, and both are relatively temporary. The first is to pop open a terminal and type "sudo init 3", which will take you out of X and to a command line. The second, if you're looking to start during boot from a command line, involves changing the runlevel in /etc/inittab. If you don't know what you're doing in /etc, then just do the first one; you can get back into your window manager by typing "startx" at the prompt. Also, using init 3 doesn't affect your next boot, which will take you into your window manager just like before.

Hope that helps.



Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 28-12-06 21:35
I think I need to clarify my network problem: I want to go wardriving with some of my friends, and I want to change the default WiFi manager to something more convenient, so I can detect and change networks easier. This means I wont' know any of the specs of the network before connecting. I also want to sniff the WEP and WPA stuff for later cracking, but airodump isn't really working. I suspect I don't have the chipsets.

Apparently I need to use telinit, not init. I will now try to install the drivers, but I expect to get another error like one I did on runlevel 1 involving xorg.conf. Would anyone know what the problem would be with that? When I was doing this a few months ago on my desktop I remember a site (I think the X wiki) that had instructions, but I don't know where it is now.

Thanks for all the willingness to help, its a testament to the HbH community :happy:


Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 28-12-06 21:43
Copy-Paste of terminal:

******************:~$ sudo telinit 3
******************:~$ runlevel
3 3

So I'm on runlevel three apparently, yet when I launch the driver installer, I'm still running an X server.
Is there any other way? Also, "cat /etc/inittab" returns a lack of the file. Are you sure that's the whereabouts of the file on Ubuntu 6.1?


Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 28-12-06 23:43
Prometheum wrote:
Copy-Paste of terminal:

******************:~$ sudo telinit 3
******************:~$ runlevel
3 3

So I'm on runlevel three apparently, yet when I launch the driver installer, I'm still running an X server.
Is there any other way? Also, "cat /etc/inittab" returns a lack of the file. Are you sure that's the whereabouts of the file on Ubuntu 6.1?


Wow... that really sucks. I booted up my Ubuntu Dapper (6.06) LiveCD and /etc/inittab is there. Checked out my test system running Ubuntu Edgy (6.1) Server and it's not! Alright, I've done a bit of reading and found that they decided to use Upstart with 6.1 and higher... so, there's no inittab. Nearly ripped my hair out from trying to find how to change the default runlevel (!!!) in Edgy until I found this answer...

"Now add an entry in /boot/grub/menu.lst to boot to run level 3

At the end of the kernel line add a "3" (without quotes)
Lilke this
Quote:
kernel=/boot/vmlinuz.... root=/dev/..... ro quiet splash 3"

...from this forum: http://www.ubuntuforums.org/showthread.php?t=319687&highlight=Edgy+runlevel

Dunno if it's the same problem as yours, but looks like the same solution. Hope that helps. Christ, I think I'll go install Gentoo now to make myself feel better...




Author

RE: Ubuntu Problems

regret
Member



Posts: 144
Location: edge of existence...
Joined: 16.10.06
Rank:
Apprentice
Posted on 29-12-06 03:18
In ubuntu, there is a booting mode called recovery mode which should allow you to boot in terminal mode only. Try editing your xorg.conf file in the shell it provides there...but who am I to say, I just screwed up my slackware 10.2 distro trying to install my ATi mobility drivers. (oh, well...time to continue my distro whoring anyway ON TO===> Knoppix)


www.hellboundhackers.org/sig/r/12852.png
I am the machine that reveals the truth to you as only I can see it.

Memories are nice, but that\'s all they are....memories.

You can\'t ever find a place that\'s nice and peaceful, because there isn\'t any. You may think there is, but once you get there, when you\'re not looking, somebody\'ll sneak up and write \'Fuck you\' right under your nose.
di3m0nd6ack www.regretexistence.com
Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 29-12-06 03:49
Recovery mode is runlevel 1, @previous poster. but...

Oh yay, I just get to muck about with my boot loader. Only good can come of that...

Hm. Why is it that when I do the runlevel command on a normal terminal I get N 2?


Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 29-12-06 04:30
After I did muck around with my boot loader, I booted up and noticed absolutely no difference. So I then booted into recovery mode (runlevel 1) and tried switching UP to runlevel 3. Well, as it turns out, RUNLEVEL THREE HAS X. RUNLEVEL TWO HAS X. EVERY RUNLEVEL EXCEPT ONE HAS X. This explains why nothing was happening when I was switching to other runlevels earlier. I was switching, but I didn't have verbose on so I wasn't seeing anything get printed and of course X wasn't stopping.

This brings me back to my original question: How exactly do I kill X?


Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 29-12-06 05:15
And as my late night oddesey continues, I apparently have the driver installed, but I have the wrong kernel module mismatching the X module. The X module is 9746, while the Nvidia kernel module is 74 something. Is there any way I can install just the Nvidia kernel module?


Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 29-12-06 05:44
Okay, Latest update:

I went to the binary driver walkthrough on the ubuntu wiki (https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia?highlight=%28nvidia%29) and did all the steps. When I restarted X, I saw the Nvidia splash screen, however, when I restarted my computer, X couldn't start due to the same kernel module inaccuracy.

Help?


Author

RE: Ubuntu Problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 29-12-06 08:02
aaaand in my fifth consecutive post in a thread I hope will become extinct, I have fixed my graphics problem completely. the right command is sudo /etc/init.d/gdm stop to kill gnome and X and then start to launch it again. I also needed to uninstall the kernel package that was giving me the version mismatch error. Also, I think I have removed the power from the hands of Network Manager and put it into whatever interface can wield it.

Many thanks to anyone who posted with helpful advice. Your contributions were invaluable and very much appreciated.