Follow us on Twitter!
The measure of a mans life is not how well he dies, but how well he lives.
Monday, April 21, 2014
Navigation
Home
HellBoundHackers Main:
HellBoundHackers Find:
HellBoundHackers Information:
Learn
Communicate
Submit
Shop
Challenges
HellBoundHackers Exploit:
HellBoundHackers Programming:
HellBoundHackers Think:
HellBoundHackers Track:
HellBoundHackers Patch:
HellBoundHackers Other:
HellBoundHackers Need Help?
Other
Members Online
Total Online: 23
Guests Online: 21
Members Online: 2

Registered Members: 82856
Newest Member: djtonyg
Latest Articles
View Thread

HellBound Hackers | Computer General | Trouble Shooting

Author

nmap problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 23-12-05 06:42
ok so two days ago I had nmap on my computer and it was working just fine when for some reason I uninstalled it. So today I install it again on the same directory with the same name and I try to scan a host and it gives me this error
Code
Starting Nmap 3.95 ( http://www.insecure.org/nmap ) at 2005-12-23 01:40 Eastern
Standard Time
dnet: Failed to open device eth0
QUITTING!




so i try typing
Code
C:\nmap>nmap 127.0.0.1

Starting Nmap 3.95 ( http://www.insecure.org/nmap ) at 2005-12-23 01:40 Eastern
Standard Time
Skipping SYN Stealth Scan against localhost (127.0.0.1) because Windows does not
 support scanning your own machine (localhost) this way.
All 0 scanned ports on localhost (127.0.0.1) are: unknown

Nmap finished: 1 IP address (1 host up) scanned in 0.156 seconds




and I just cant fix it please help me.


Author

RE: nmap problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 23-12-05 07:10
Try scanning your router not localhost...

The first error Im not sure about but the second error Its kinda common sense what they are saying...


Code
C:\Tools\nmap>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        IP Address. . . . . . . . . . . . : 192.168.1.103
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1

C:\Tools\nmap>nmap 127.0.0.1

Starting nmap 3.93 ( http://www.insecure.org/nmap ) at 2005-12-22 23:13 Pacific
Standard Time
Skipping SYN Stealth Scan against localhost (127.0.0.1) because Windows does not
 support scanning your own machine (localhost) this way.
All 0 scanned ports on localhost (127.0.0.1) are: unknown

Nmap finished: 1 IP address (1 host up) scanned in 0.031 seconds

C:\Tools\nmap>nmap 192.168.1.1

Starting nmap 3.93 ( http://www.insecure.org/nmap ) at 2005-12-22 23:13 Pacific
Standard Time
Interesting ports on 192.168.1.1:
(The 1667 ports scanned but not shown below are in state: closed)
PORT   STATE SERVICE
80/tcp open  http

Nmap finished: 1 IP address (1 host up) scanned in 2.360 seconds

C:\Tools\nmap>







Edited by on 23-12-05 07:15
Author

RE: nmap problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 23-12-05 15:16
nope I get the same error
Code
C:\nmap>nmap 192.168.1.1

Starting Nmap 3.95 ( http://www.insecure.org/nmap ) at 2005-12-23 10:15 Eastern
Standard Time
dnet: Failed to open device eth0
QUITTING!

C:\nmap>





Author

RE: nmap problems


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 23-12-05 15:26
dnet: Failed to open device eth0

=> I would say hardware issues accroding to this line. Have you installed any new drivers lately

PS I'm not a big expert with nmap. To be honest, I rarely use it Wink


Author

RE: nmap problems

n3w7yp3
Member

Your avatar

Posts: 358
Location: USA
Joined: 19.03.05
Rank:
Moderate
Posted on 23-12-05 16:07
dnet is a raw packe manipulation library (libdnet).

I've never used nmap on Windows before (I'm a Linux user), but I'd suggest that you try to install libdnet, and make sure that you have all the correct winpcap modules installed.

BTW, eth0 is your ethernet card, in case you were wondering Wink


"Root is a state of mind" -- K0resh