Join us on Slack!
Society leans ever heavily on computers, if you have the power to take out computers you can take out society. - cubeman372
Sunday, May 26, 2019
Navigation
Home
 Find:
 Information:
Learn
Communicate
Submit
Shop
Challenges
 Exploit:
 Programming:
 Think:
 Track:
 Patch:
 Other:
 Need Help?
Other
Members Online
Total Online: 74
Guests Online: 73
Members Online: 1

Registered Members: 114244
Newest Member: Charlesestax
Latest Articles
View Thread

HellBound Hackers | Computer General | General Computer Problems

Author

Gentoo - revdep-rebuild "not owned by any package"

stealth-
Member



Posts: 1003
Location: Eh?
Joined: 10.04.09
Rank:
Mad User
Posted on 05-02-12 09:18
For the last while, whenever I run a revdep-rebuild, I see this in the output:

stealth@renascence ~ $ revdep-rebuild
* You are not superuser. Adding --pretend to emerge options.
* Configuring search environment for revdep-rebuild

* Checking reverse dependencies
* Packages containing binaries and libraries broken by a package update
* will be emerged.

* Collecting system binaries and libraries
* Generated new 1_files.rr
* Collecting complete LD_LIBRARY_PATH
* Generated new 2_ldpath.rr
* Checking dynamic linking consistency
[ 35% ] * broken /usr/libexec/gnome-screensaver/biof (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/busyspheres (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/colorfire (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/cyclone (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/euphoria (requires libGLEW.so.1.5)
[ 36% ] * broken /usr/libexec/gnome-screensaver/feedback (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/fieldlines (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/flocks (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/flux (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/helios (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/hufo_smoke (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/hufo_tunnel (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/hyperspace (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/lattice (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/lorenz (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/plasma (requires libGLEW.so.1.5)
[ 37% ] * broken /usr/libexec/gnome-screensaver/skyrocket (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/solarwinds (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/spirographx (requires libGLEW.so.1.5)
* broken /usr/libexec/gnome-screensaver/sundancer2 (requires libGLEW.so.1.5)
[ 82% ] * broken /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/protocols/_c_urlarg.so (requires libpython2.6.so.1.0)
* broken /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/python/_epoll.so (requires libpython2.6.so.1.0)
* broken /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/python/_initgroups.so (requires libpython2.6.so.1.0)
[ 83% ] * broken /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/runner/portmap.so (requires libpython2.6.so.1.0)
* broken /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/test/raiser.so (requires libpython2.6.so.1.0)
[ 86% ] * broken /usr/lib/python2.6/site-packages/zope.interface-3.5.3-py2.6-linux-i686.egg/zope/interface/_zope_interface_coptimizations.so (requires libpython2.6.so.1.0)
[ 100% ]
* Generated new 3_broken.rr
* Assigning files to packages
* !!! /usr/libexec/gnome-screensaver/biof not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/biof -> (none)
* !!! /usr/libexec/gnome-screensaver/busyspheres not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/busyspheres -> (none)
* !!! /usr/libexec/gnome-screensaver/colorfire not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/colorfire -> (none)
* !!! /usr/libexec/gnome-screensaver/cyclone not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/cyclone -> (none)
* !!! /usr/libexec/gnome-screensaver/euphoria not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/euphoria -> (none)
* !!! /usr/libexec/gnome-screensaver/feedback not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/feedback -> (none)
* !!! /usr/libexec/gnome-screensaver/fieldlines not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/fieldlines -> (none)
* !!! /usr/libexec/gnome-screensaver/flocks not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/flocks -> (none)
* !!! /usr/libexec/gnome-screensaver/flux not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/flux -> (none)
* !!! /usr/libexec/gnome-screensaver/helios not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/helios -> (none)
* !!! /usr/libexec/gnome-screensaver/hufo_smoke not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/hufo_smoke -> (none)
* !!! /usr/libexec/gnome-screensaver/hufo_tunnel not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/hufo_tunnel -> (none)
* !!! /usr/libexec/gnome-screensaver/hyperspace not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/hyperspace -> (none)
* !!! /usr/libexec/gnome-screensaver/lattice not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/lattice -> (none)
* !!! /usr/libexec/gnome-screensaver/lorenz not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/lorenz -> (none)
* !!! /usr/libexec/gnome-screensaver/plasma not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/plasma -> (none)
* !!! /usr/libexec/gnome-screensaver/skyrocket not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/skyrocket -> (none)
* !!! /usr/libexec/gnome-screensaver/solarwinds not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/solarwinds -> (none)
* !!! /usr/libexec/gnome-screensaver/spirographx not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/spirographx -> (none)
* !!! /usr/libexec/gnome-screensaver/sundancer2 not owned by any package is broken !!!
* /usr/libexec/gnome-screensaver/sundancer2 -> (none)
* !!! /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/protocols/_c_urlarg.so not owned by any package is broken !!!
* /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/protocols/_c_urlarg.so -> (none)
* !!! /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/python/_epoll.so not owned by any package is broken !!!
* /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/python/_epoll.so -> (none)
* !!! /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/python/_initgroups.so not owned by any package is broken !!!
* /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/python/_initgroups.so -> (none)
* !!! /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/runner/portmap.so not owned by any package is broken !!!
* /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/runner/portmap.so -> (none)
* !!! /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/test/raiser.so not owned by any package is broken !!!
* /usr/lib/python2.6/site-packages/Twisted-10.0.0-py2.6-linux-i686.egg/twisted/test/raiser.so -> (none)
* !!! /usr/lib/python2.6/site-packages/zope.interface-3.5.3-py2.6-linux-i686.egg/zope/interface/_zope_interface_coptimizations.so not owned by any package is broken !!!
* /usr/lib/python2.6/site-packages/zope.interface-3.5.3-py2.6-linux-i686.egg/zope/interface/_zope_interface_coptimizations.so -> (none)
* Generated new 4_raw.rr and 4_owners.rr
* Found some broken files, but none of them were associated with known packages
* Unable to proceed with automatic repairs.
* The broken files are listed in 4_owners.rr
stealth@renascence ~ $


Emerge isn't ran, I'm assuming because it can't find packages to link these to. So, what on earth do I do with those files? Delete them? They don't work I would imagine, being broken, but I can't recompile them against new libraries as I don't know what package they map to. Any ideas how to fix these errors in the most clean way?


The irony of man's condition is that the deepest need is to be free of the anxiety of death and annihilation; but it is life itself which awakens it, and so we must shrink from being fully alive.
http://www.stealt. . .

Edited by stealth- on 05-02-12 09:18
http://www.stealth-x.com
Author

RE: Gentoo - revdep-rebuild "not owned by any package"

Arabian
Banned



Posts: 332
Location: inside you.
Joined: 22.09.10
Rank:
Apprentice
Posted on 08-02-12 01:17
have you tried eclean?


G'bye y'all! I was an asshole, So korg banned me.
Author

RE: Gentoo - revdep-rebuild "not owned by any package"

stranac
Member



Posts: 151
Location:
Joined: 15.11.08
Rank:
God
Posted on 08-02-12 10:30
Yeah, just delete them. And then run `revdep-rebuild -i`. That should make it work.
Author

RE: Gentoo - revdep-rebuild "not owned by any package"

korg
Member



Posts: 2803
Location: ENDING YOUR ONLINE EXPERIENCE!
Joined: 01.01.06
Rank:
God
Posted on 09-02-12 14:18
stranac wrote:
Yeah, just delete them. And then run `revdep-rebuild -i`. That should make it work.


No don't delete them first.
Run revdep-rebuild --ignore --pretend
If emerge is still unhappy, MOVE the files to another location. (You might need them if a package gets pissy)
The run revdep-rebuild --ignore --pretend
See what happens if all is good run just revdep-rebuild.

It's been a while since I used gentoo but I recalled having this problem and this is what worked for me.


i57.photobucket.com/albums/g215/korg1269/shodan13.jpg

I deal in pain, All life I drain, I dominate, I seal your fate.
O R
Author

RE: Gentoo - revdep-rebuild "not owned by any package"

stealth-
Member



Posts: 1003
Location: Eh?
Joined: 10.04.09
Rank:
Mad User
Posted on 11-02-12 22:19
korg wrote:
stranac wrote:
Yeah, just delete them. And then run `revdep-rebuild -i`. That should make it work.


No don't delete them first.
Run revdep-rebuild --ignore --pretend
If emerge is still unhappy, MOVE the files to another location. (You might need them if a package gets pissy)
The run revdep-rebuild --ignore --pretend
See what happens if all is good run just revdep-rebuild.

It's been a while since I used gentoo but I recalled having this problem and this is what worked for me.


Thanks Korg, that fixed it Grin

Arabian wrote:
have you tried eclean?


Mother of god that cleaned out a lot of space 0.0
Wasn't aware of eclean, or that I needed to clean out DISTDIR.

Thanks everyone, system looks all cleaned up now ;D


The irony of man's condition is that the deepest need is to be free of the anxiety of death and annihilation; but it is life itself which awakens it, and so we must shrink from being fully alive.
http://www.stealt. . .
http://www.stealth-x.com