Follow us on Twitter!
It is never to LATE to become what you never WERE.
Saturday, April 19, 2014
Navigation
Home
HellBoundHackers Main:
HellBoundHackers Find:
HellBoundHackers Information:
Learn
Communicate
Submit
Shop
Challenges
HellBoundHackers Exploit:
HellBoundHackers Programming:
HellBoundHackers Think:
HellBoundHackers Track:
HellBoundHackers Patch:
HellBoundHackers Other:
HellBoundHackers Need Help?
Other
Members Online
Total Online: 25
Guests Online: 25
Members Online: 0

Registered Members: 82839
Newest Member: fezphantom
Latest Articles
View Thread

HellBound Hackers | Computer General | Networking

Author

wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 22-09-08 00:24
Ok, so ive got a wireless network setup to share my connection, unfortunately it only supports wep, so im lumbered with that. The connection works (i can use my phone on it), but when I come to hook up my lappy to it dhcp just wont play ball. I can connect unencrypted, dhcp works fine then, and im pretty sure my wep settings are fine, so im stumped.

Ive tried using wlassistant, which finds my network (full signal) and I put the correct settings in there. All seems to go well, but dhcp doesnt get an IP so the connection fails.

Ive also tried the iwconfig way(manually), using these commands:

Code

iwconfig ath0 mode managed channel 6 key restricted s:<my key> essid <my essid>
iwconfig ath0 ap <my AP mac>




then both of these:
Code

dhcpcd -nd ath0

dhclient ath0




Both fail, dhclient claims there were no DHCP offers, but my phone gets connected in a few seconds, so I know it works.

iwconfig for my ath0 interface here: http://pastebin.c. . .

Any help would be appreciated.


Author

RE: wireless connect issue

spyware
Member



Posts: 4192
Location: The Netherlands
Joined: 14.04.07
Rank:
God
Warn Level: 90
Posted on 22-09-08 00:28
WEP key hex or ascii?

Edit: Nvm.



img507.imageshack.us/img507/3580/spynewsig3il1.png
"The chowner of property." - Zeph
[small]
Widespread intellectual and moral docility may be convenient for leaders in the short term,
but it is suicidal for nations in the long term.
- Carl Sagan
“Since the grid is inescapable, what were the earlier lasers about? Does the corridor have a sense of humor?” - Ebert
[/s

Edited by spyware on 22-09-08 00:30
http://bitsofspy.net
Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 22-09-08 01:55
Wasn't mentioned in your initial post... are you using a native Linux driver for your wireless, or are you using ndiswrapper for it? Distro, version, and laptop model?


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 22-09-08 12:32
Im using the patched madwifi drivers with BT3 final, on an atheros based card. I can connect to unencrypted networks, so I know the card is fully functional, but I just cant get WEP to work.


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 22-09-08 13:16
Well, it's unlikely that you have one of the newer Atheros cards that still has issues despite the patches on Madwifi. Most likely, it's just a quirk with something other than your wireless connection, whose iwconfig looks fine. Try bringing down any other interfaces (so just ath0 / wifi0 / wlan0 and lo are up), then try the dhcp request again. If that doesn't work, try specifying the default gateway for ath0 in a normal route command; if that doesn't work, specify the route specifically for that interface. If none of that works, see if you can ping anything on the internal network.


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 22-09-08 20:58
On Ubuntu Hardy Heron (8.04) athreos cards were alot of trouble for me, But I solved it by going into the router and just editing the setting in that.

this may help if you can follow it loosely.

http://www.lycoming.edu/acad/linksys%20wireless-g%20broadband%20router.htm

Also, if you set the router to accept you laptops MAC address that may help, But I'm not so sure if that will "fix" your problem.


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 22-09-08 21:48
Ive not got any sort of mac filtering on, its accepting all clients.


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 23-09-08 18:55
I had a similar problem with my Ubuntu...What I do now is I use KWifiManager and Wireless Assistant to connect to WEP networks.

Basically you set up KWifiManager with your info and then set up Wireless Assistant too and you have both open while trying to connect via Wireless Assistant.
For me, if I close one and keep the other open it doesn't work. Don't ask me why, I have no idea and I've never felt the need to figure it out but it works. I had a friend with a similar problem and this solution worked on his laptop too.



Author

RE: wireless connect issue

spyware
Member



Posts: 4192
Location: The Netherlands
Joined: 14.04.07
Rank:
God
Warn Level: 90
Posted on 23-09-08 19:03
ice_sd wrote:
I had a similar problem with my Ubuntu...

snip

I have no idea and I've never felt the need to figure it out


Good job on solving your problems. Anyways, I'll be referring to this post for "Ubuntu-people" proof.

Thanks ice_sd!



img507.imageshack.us/img507/3580/spynewsig3il1.png
"The chowner of property." - Zeph
[small]
Widespread intellectual and moral docility may be convenient for leaders in the short term,
but it is suicidal for nations in the long term.
- Carl Sagan
“Since the grid is inescapable, what were the earlier lasers about? Does the corridor have a sense of humor?” - Ebert
[/s
http://bitsofspy.net
Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 23-09-08 19:19
spyware wrote:
ice_sd wrote:
I had a similar problem with my Ubuntu...

snip

I have no idea and I've never felt the need to figure it out


Good job on solving your problems. Anyways, I'll be referring to this post for "Ubuntu-people" proof.

Thanks ice_sd!


Hey, at least I solved it on my own without bothering cocky assholes such as yourself for help.


Author

RE: wireless connect issue

spyware
Member



Posts: 4192
Location: The Netherlands
Joined: 14.04.07
Rank:
God
Warn Level: 90
Posted on 23-09-08 19:25
ice_sd wrote:
Hey, at least I solved it on my own without bothering cocky assholes such as yourself for help.


When I said "good job", I actually meant "good job". I was being sincere, not sarcastic. I see how you got those two mixed up though. (Again, I'm not being sarcastic here, -really-!).

Aaaaaaanyway, keep on posting quality stuff ice!



img507.imageshack.us/img507/3580/spynewsig3il1.png
"The chowner of property." - Zeph
[small]
Widespread intellectual and moral docility may be convenient for leaders in the short term,
but it is suicidal for nations in the long term.
- Carl Sagan
“Since the grid is inescapable, what were the earlier lasers about? Does the corridor have a sense of humor?” - Ebert
[/s
http://bitsofspy.net
Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 23-09-08 23:29
@ice - Thanks for the input, but ive tried that as well unfortunately, as well as using KDE control center to load the settings on start, I wanted to take the non-GUI way, as I understand this stuff pretty well, and would love to get to the bottom of whats gone wrong here.

Saying that I am still utterly stumped :angry:


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 24-09-08 00:26
jjbutler88 wrote:
Saying that I am still utterly stumped :angry:

I take it you tried what I listed in my post, then.


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 24-09-08 00:41
Yeah, all but adding the default gateway, purely coz im not sure what IP it will be, when I connect my phone I get a 10.0.1.x number, but my ifconfig for my wireless says a 169.x.x.x number. I know the command for adding a default route, so il try both and see what happens. Never normally had to do this before though, including the same connection, just without wep.


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 24-09-08 01:00
A 169.254.x.x address means that your DHCP requests aren't getting a response... but, we know that already. The reasoning behind my post was as follows:

Sometimes, it seems as if the traffic wants to go out of the Ethernet connection only if both Ethernet and wireless are up. Bringing the Ethernet interface down solves that, but may remove some of the default routes associated with it (including the default gateway).

... Before I get too far along: You don't know what IP your gateway will have? How on Earth is it handing out DHCP requests, then? If it's not, what is? How are you getting a connection on your phone if there's no device to serve as a gateway with a set IP?


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 24-09-08 12:55
Ok il explain more. I am using my imac as a wireless router, so I can see from the terminal that the IP address of the interface itself is 169.x.x.x - however when I look at my phone, it says that its IP is in the 10.0.1.x subnet... hence my confusion.


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 24-09-08 13:12
Okay, two questions about your topology:

1. Is the iMac routing to outside your network as well, or just sharing a connection over wireless? (What device is taking the connection from the outside and passing it through to your network?)
2. What device is a DHCP server on your network?

Can't really figure anything else out until I know both of those.


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 24-09-08 16:12
Yeah, my mac is taking an ethernet connection for the server at my accomodation, so there is a dhcp server assigning my mac an IP, but my mac is sharing that over the wireless (go hostap Grin), so my mac is also acting as a DHCP server.

Its complex :whoa:


Author

RE: wireless connect issue


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 24-09-08 16:20
Seems like it. Find the IP of the iMac, then assign a static IP just a bit lower/higher than that to your laptop. Try to connect to the AP again and see if that allows you to ping/connect to anything. We'll just go ahead and try to eliminate DHCP problems to narrow down the issue. Also, try pinging the IP of the iMac after you've done that; you won't need to assign a default gateway to ping the 1st hop away from your laptop.

Also, find the MAC (no pun intended) address of the iMac's wireless NIC and assign that as the "ap" parameter when you do iwconfig. So, total, try specifying the essid, mode (managed), ap, key (open/restricted and the key), and IP / mask (with ifconfig) for the WNIC on your laptop.

Post back with how that all goes.




Edited by on 24-09-08 16:21