Follow us on Twitter!
Become the change you seek in the world. - Gandhi
Saturday, December 10, 2016
Navigation
Home
 Find:
 Information:
Learn
Communicate
Submit
Shop
Challenges
 Exploit:
 Programming:
 Think:
 Track:
 Patch:
 Other:
 Need Help?
Other
Members Online
Total Online: 22
Guests Online: 20
Members Online: 2

Registered Members: 96881
Newest Member: MrJ
Latest Articles
View Thread

HellBound Hackers | Computer General | General Computer Problems

Author

Metasploit linux help


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 20-05-07 04:12
I've installed metasploit and rubygems, along with rail, and I try to run msfgui and it gives me an error. Can anyone tell me how to get the packages I need?

root@darkparad0x:/home/chris/framework-3.0# ./msfgui
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_boxed_type_register_static: assertion `g_type_from_name (name) == 0' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_param_spec_boxed: assertion `G_TYPE_IS_BOXED (boxed_type)' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_param_spec_boxed: assertion `G_TYPE_IS_BOXED (boxed_type)' failed
/usr/lib/ruby/1.8/glib2.rb: line 55
GLib-GObject-CRITICAL **:g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
[*] The msfgui interface requires the ruby-gtk2 and ruby-libglade2 package
root@darkparad0x:/home/chris/framework-3.0#

I've tried to sudo apt-get install blah blah but it couldn't find them..help would be greatly appreciated Pfft.


Author

RE: Metasploit linux help


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 20-05-07 04:27
Um..never I'm retarded, forgot to reboot, all good now.