Follow us on Twitter!
Society leans ever heavily on computers, if you have the power to take out computers you can take out society. - cubeman372
Thursday, September 21, 2017
Navigation
Home
 Find:
 Information:
Learn
Communicate
Submit
Shop
Challenges
 Exploit:
 Programming:
 Think:
 Track:
 Patch:
 Other:
 Need Help?
Other
Members Online
Total Online: 59
Guests Online: 58
Members Online: 1

Registered Members: 101983
Newest Member: anilchowdary
Latest Articles
View Thread

HellBound Hackers | HellBound Hackers | Questions

Author

Metasploit latest ruby incompatible


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 19-03-09 18:33
Hey,

upgraded everything and it just doesn't seem to work, after some googeling it seems it my ruby or ruby on rails that ive updated.

Anyone knows how to fix this issue? Seems its something with the strings or so...

[root@asfsdf framework-3.2]# ./msfconsole
/home/OMG/framework-3.2/lib/msf/core/exploit.rb:229:in `require': /home/OMG/framework-3.2/lib/msf/core/exploit/smb.rb:401: invalid multibyte char (US-ASCII) (SyntaxError)
/home/OMG/framework-3.2/lib/msf/core/exploit/smb.rb:401: syntax error, unexpected tIDENTIFIER, expecting 'Wink'
Rex::Text.to_unicode('Ta33;voli nyomtata33;k'Wink
^
/home/OMG/framework-3.2/lib/msf/core/exploit/smb.rb:401: invalid multibyte char (US-ASCII)
from /home/OMG/framework-3.2/lib/msf/core/exploit.rb:229:in `<class:Exploit>'
from /home/OMG/framework-3.2/lib/msf/core/exploit.rb:28:in `<module:Msf>'
from /home/OMG/framework-3.2/lib/msf/core/exploit.rb:3:in `<top (required)>'
from /home/OMG/framework-3.2/lib/msf/core.rb:48:in `require'
from /home/OMG/framework-3.2/lib/msf/core.rb:48:in `<top (required)>'
from /home/OMG/framework-3.2/lib/msf/ui/console/driver.rb:1:in `require'
from /home/OMG/framework-3.2/lib/msf/ui/console/driver.rb:1:in `<top (required)>'
from /home/OMG/framework-3.2/lib/msf/ui/console.rb:10:in `require'
from /home/OMG/framework-3.2/lib/msf/ui/console.rb:10:in `<top (required)>'
from /home/OMG/framework-3.2/lib/msf/ui.rb:10:in `require'
from /home/OMG/framework-3.2/lib/msf/ui.rb:10:in `<top (required)>'
from ./msfconsole:12:in `require'
from ./msfconsole:12:in `<main>'