Follow us on Twitter!
The important thing is not to stop questioning. - Albert Einstein
Wednesday, April 16, 2014
Navigation
Home
HellBoundHackers Main:
HellBoundHackers Find:
HellBoundHackers Information:
Learn
Communicate
Submit
Shop
Challenges
HellBoundHackers Exploit:
HellBoundHackers Programming:
HellBoundHackers Think:
HellBoundHackers Track:
HellBoundHackers Patch:
HellBoundHackers Other:
HellBoundHackers Need Help?
Other
Members Online
Total Online: 17
Guests Online: 15
Members Online: 2

Registered Members: 82808
Newest Member: Krish
Latest Articles
View Thread

HellBound Hackers | Computer General | General Computer Problems

Author

gentoo autoloading modules


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 27-09-08 20:11
hi,
i want to use opensource ati drivers, so i emerged it, and set in xorg.conf, but i still get error
Code
(WW) RADEON(0): [agp] AGP not available
(EE) RADEON(0): [agp] AGP failed to initialize. Disabling the DRI.
(II) RADEON(0): [agp] You may want to make sure the agpgart kernel module
is loaded before the radeon kernel module.



so i used google and i find, that i have to load ati-agp and agpgart, before radeonfb, so i edited /etc/modules.autoload.d/kernel-2.6 and get ati-agp and agpgart on top, restarted, and i get thesame problem, and when i used lsmod i found that first was loaded readeon, and ati-agp wasn't loaded, so i want ask, what may be wrong with autoloading? thanks
Author

RE: gentoo autoloading modules


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 27-09-08 20:50
Try running "modprobe ati-agp", and the same for the other module, in a terminal and see what the response is. If it's in your autoload, it should load. Also, you could try running "dmesg | grep ati-agp" to see any errors... same with the other module.

Also, I think general AGP support is in the kernel modules. To check the kernel in Gentoo, you can run the following:

cd /usr/src/linux
make menuconfig

Then, just try to find anything that looks like it pertains to AGP; if there are listings and the ( ) beside them have nothing in them, press Spacebar to either load them as a module (M) or with the kernel (*). If the AGP modules weren't checked, you'll need to re-compile your kernel. The kernel compiling process (in all its wonderful simplicity in Gentoo) is documented here:
http://www.gentoo. . .pgrade.xml

Post back with what you find.

Edit: Just re-read this quote...
mojdo13 wrote:
You may want to make sure the agpgart kernel module
is loaded before the radeon kernel module.

Most likely, you aren't loading AGP drivers or you're loading them as modules. Compile them into the kernel (by setting them with a * instead of M) in the make menuconfig, then follow the link above.




Edited by on 27-09-08 20:56
Author

RE: gentoo autoloading modules


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 27-09-08 20:57
i found out that i have intel agp chitpset not ati :-D:-D, so i make new kernel with intel agp, i added intel-agp, it loaded, but get another error
Code
(II) [drm] DRM interface version 1.0
(EE) [drm] Could not set DRM device bus ID.
(EE) RADEON(0): [dri] DRIScreenInit failed.  Disabling DRI.



i used google and i found that
http://www.phoronix.com/forums/showthread.php?t=12777
and if i understood, problem may be that i compiled kernel and drm module with another gcc, but, when i was compilling kernel i used "make clean bzImage modules modules_install" so i think that kernel and module, was compilled by thesame gcc, or i have to recompille something else?
thanks
Author

RE: gentoo autoloading modules


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 27-09-08 21:02
If you're getting those errors when trying to "startx" (which is what it looks like), you need to make sure that your /etc/X11/xorg.conf lists your driver as "intel" or "i815" (or even "vesa"), not "ati" or "radeon" or whatever. If that doesn't help, run "lsmod" and paste the results here.

In the future, use the "lspci" command to find your hardware devices.




Edited by on 27-09-08 21:03
Author

RE: gentoo autoloading modules


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 27-09-08 21:24
ok i don't think there have to be intel or something else i think there have to be radeon, because i have ati radeon x1650, but chipset that control agp is intel...or am i wrong?
edit: i try rebuild some packages, and then write there if it helps

Edited by on 27-09-08 21:31
Author

RE: gentoo autoloading modules


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 27-09-08 21:36
Let's try something else. Run "lspci -nn" and make note of the bus IDs (PCI:02:01 or whatever) for your ATI card and your Intel onboard display controller (if there is one). Then, go into your Xorg.conf and check to make sure the ID in the Device section for your Radeon matches what was listed with lspci. If so, then see if DRI is listed as an option in that Device section; put a # in front of it to disable that, then try "startx" again.


Author

RE: gentoo autoloading modules


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 27-09-08 21:58
ok i found problem, i was testing my edited xorg.conf by using xinit -- :2 -config /etc/X11/xorg.conf.test and then looked at /var/log/Xorg.2.log, if i used it normally, everythink is ok, just one last qustion, where can i find some list of XkbLayout, and XkbVariant, thanks for help
Author

RE: gentoo autoloading modules


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 27-09-08 22:03
Most likely at the Xorg wiki. Glad you found the problem. Was there any specific differences between the one you were testing and the one that worked that would've been causing the problems?


Author

RE: gentoo autoloading modules


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 27-09-08 22:15
ok i explain it, i'm trying to run compiz-fusion, but firstly i have to config driver, i can't use official because they don't support my version of xorg-server, so i used xf86-video-ati, and then i must config my xorg.conf, before i haven't used it, xorg was running without it, but now i need to use ati driver, so i must configure my xorg.conf, so i maked xorg.conf.test and testing it in xinit -- :2 -config /etc/X11/xorg.conf.bak, so i never restarted Xorg and tryied it, it was one of thing that i can try, to make it work was to restart X with new config and it worked :-D:-D...many thanks for help
Author

RE: gentoo autoloading modules


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 27-09-08 22:32
and just one last question is difference between
option "something" "true"
option "something" "yes"
option "something" "on"
or is it everithing thesame?
Author

RE: gentoo autoloading modules


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 27-09-08 23:05
I'd imagine it's specific to the option you're configuring.


Author

RE: gentoo autoloading modules

fashizzlepop
Member



Posts: 482
Location: Old folks home.
Joined: 08.04.08
Rank:
Moderate
Posted on 28-09-08 08:33
For some reason I feel the need to say this...

yours31f could learn a lot from these posts. They are all detailed and help with the problem. Not just vague crappy responses. These posts by Zephyr make me want to go out an learn aboot what the hell these guys are really talking aboot.

I applaud you.


"The definition of insanity is doing the same thing over and over again and expecting different results.
~Albert Einstein~


csullivan.codeinspire.net/images/boomsig2.png
fashizzlepop@gmail.com http://csullivan.codeinspire.net/