Follow us on Twitter!
Things are more like they are now than they have ever been before. - Dwight D. Eisenhower
Friday, April 18, 2014
Navigation
Home
HellBoundHackers Main:
HellBoundHackers Find:
HellBoundHackers Information:
Learn
Communicate
Submit
Shop
Challenges
HellBoundHackers Exploit:
HellBoundHackers Programming:
HellBoundHackers Think:
HellBoundHackers Track:
HellBoundHackers Patch:
HellBoundHackers Other:
HellBoundHackers Need Help?
Other
Members Online
Total Online: 23
Guests Online: 22
Members Online: 1

Registered Members: 82826
Newest Member: Jakob
Latest Articles
View Thread

HellBound Hackers | Computer General | Networking

Author

ESSID problems in Slackware


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 02-09-08 05:53
Alright, I don't generally like to actually... start threads, but I'm having some strange issues with my Slackware install. The laptop I've installed Slackware on has Realtek 8187B Wireless.

I initially tried the Linux drivers for that model from the Realtek site, but they were erroring out. Found some patched Linux drivers for that model, tried those... still erroring out. Checked the errors on both, and they're not caused by faulty hardware... it is likely the kernel version (2.6.24.5).

So, I hopped over to ndiswrapper's Sourceforge page and grabbed version 1.53. Installed just fine, found a nice little tut about how to modify the .inf file from the Windows 8187B driver so that it would work with Linux... so, made that change (having a line in the driver for the ID that shows up when running "lsusb") and the driver installed just fine.

Linux recognizes the wireless interface (wlan0) and, after running "iwlist wlan0 scan", I can see the WAP that I temporarily set to WEP to get it working initially. However, upon using "iwlist wlan0 mode", "iwlist wlan0 essid", "iwlist wlan0 key restricted"... with the proper arguments trailing, the output from the iwconfig command shows the key, mode, frequency, and security mode correctly. The ESSID won't change from "off/any" so, of course, Access Point says "Not Associated".

Don't tell me to Google, because I've been doing so for hours. I'd tried unloading and reloading the ndiswrapper module, restarting my networking, bringing down either or both of eth0 and wlan0, different orders with the iwlist commands, both "open" and "restricted" security modes in iwlist, and various combinations of the above. I've also tried just configuring the wireless through KDE's "Wireless Network" utility (under the "Settings" menu). I've made the changes to the /etc/rc.d/rc.wireless.conf file as well.

Has anyone had this type of issue before or, if you haven't, any thoughts?




Edited by on 02-09-08 05:53
Author

RE: ESSID problems in Slackware


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 02-09-08 15:53
I really dont know if this would/could effect your situation, but have you tried placing your card into manage mode?

iwconfig wlan0 mode managed essid <essid>


Author

RE: ESSID problems in Slackware

korg
Admin from hell



Posts: 2798
Location: ENDING YOUR ONLINE EXPERIENCE!
Joined: 01.01.06
Rank:
God
Posted on 02-09-08 21:04
Not to sound stupid, But I didn't see it listed in your post. Did you turn on the adapter: ifconfig ath0 up. Just a thought haven't had this issue yet.



i57.photobucket.com/albums/g215/korg1269/shodan13.jpg

I deal in pain, All life I drain, I dominate, I seal your fate.
O R
Author

RE: ESSID problems in Slackware


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 02-09-08 23:22
stdio wrote:
I really dont know if this would/could effect your situation, but have you tried placing your card into manage mode?

iwconfig wlan0 mode managed essid <essid>


Yes, I did so both using the iwlist and iwconfig commands, using both "managed" and "ad-hoc" (as I had seen this recommended for testing).

korg wrote:
Not to sound stupid, But I didn't see it listed in your post. Did you turn on the adapter: ifconfig ath0 up. Just a thought haven't had this issue yet.


Yes, I did... it comes up by default on boot but, to make sure, I have brought it down, then back up... restarted networking before, in-between, and after. On my system, the wireless is referred to as wlan0... not that it makes any difference from ath0. It's just an alias.

I appreciate someone finally responding to the thread! I thought maybe I was going to have to bump this things for weeks to get a response. Smile


Author

RE: ESSID problems in Slackware


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 03-09-08 02:23
Alright, I found another link with a bit more depth on modifying the RTL8187B inf file before installing it with ndiswrapper:

http://www.linuxq. . .er-610613/

After running "ndiswrapper -r" with the driver filename, "ndiswrapper -i" with the new file, "rmmod ndiswrapper", "modprobe ndiswrapper", and "iwconfig wlan0 mode managed essid <ssid>"... I'm back where I started, but the frequency is auto-detecting to match the channel that my WAP operates on (whereas, before, it was stuck at around 12GHz before I manually changed it). So, it can see the AP and it looks like it's trying to connect... it's just not changing the ESSID when I run the command to change it.

I think that's progress. More as I learn more... suggestions and thoughts are welcome. Smile


Author

RE: ESSID problems in Slackware

korg
Admin from hell



Posts: 2798
Location: ENDING YOUR ONLINE EXPERIENCE!
Joined: 01.01.06
Rank:
God
Posted on 03-09-08 07:34
Alright was thinking about it, But might be off (Been up all night piecing together a dv2000 some idiot took apart). Have you tried:
dhcpcd wlan0 or dhclient wlan0 (depends) to see if dhcp is started or gives any errors.




i57.photobucket.com/albums/g215/korg1269/shodan13.jpg

I deal in pain, All life I drain, I dominate, I seal your fate.
O R
Author

RE: ESSID problems in Slackware


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 03-09-08 13:43
korg wrote:
Have you tried:
dhcpcd wlan0 or dhclient wlan0 (depends) to see if dhcp is started or gives any errors.


Originally, I was just using a static address between my gateway and one of my desk machines to make sure I had it in a working subnet. Booted it up over a cup of coffee this morning and gave the dhcp commands a shot, anyways... just to say I did. It's not associating with the WAP, though, so I wouldn't be able to pull an IP.

I guess I'll keep reading up on "Off/Any" ESSID issues with ndiswrapper, check to make sure I have the current version, etc. It's only a matter of time before Slackware bends to my will. Grin


Author

RE: ESSID problems in Slackware


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 06-09-08 05:22
HA! Slackware is officially my BITCH now. Grin

Turns out that an alias must be created for wlan0 to associate itself with the ndiswrapper module... using the command "ndiswrapper -m". Rebooted, gave both the essid and ap of the WAP, gave the key... and voila!

So, just in case anyone has this problem or a similar one... here's the rundown:

1. Install ndiswrapper.
2. Go get the Windows driver for your WNIC.
3. Find the .inf file for either Win98 or WinXP (I had to use Win98).
4. Type "ndiswrapper -i filename.inf", where "filename" is the name of the file.
5. Type "depmod -a", then "modprobe ndiswrapper" to make sure it's loaded.
6. Type "ndiswrapper -m" to alias wlan0 or ath0 to ndiswrapper.
7. Reboot.
8. Type "iwlist wlan0 scan" to find your AP.
9. Use "iwconfig" with "essid", "ap", and "key", with the proper arguments.

If the wireless interface connects to the AP, add that info to your network conf so it will be configured automatically at boot. Oh, and thank you to the people who tried to help... it was much appreciated. Smile




Edited by on 06-09-08 14:53
Author

RE: ESSID problems in Slackware

spyware
Member



Posts: 4192
Location: The Netherlands
Joined: 14.04.07
Rank:
God
Warn Level: 90
Posted on 06-09-08 12:23
Zephyr_Pure wrote:
HA! Slackware is officially my BITCH now. Grin


Very impressive, congratulations on solving this problem.

However; viola should be "voilà".

Read more about this here: http://www.wsu.edu/~brians/errors/voila.html



img507.imageshack.us/img507/3580/spynewsig3il1.png
"The chowner of property." - Zeph
[small]
Widespread intellectual and moral docility may be convenient for leaders in the short term,
but it is suicidal for nations in the long term.
- Carl Sagan
“Since the grid is inescapable, what were the earlier lasers about? Does the corridor have a sense of humor?” - Ebert
[/s
http://bitsofspy.net
Author

RE: ESSID problems in Slackware


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 06-09-08 15:00
spyware wrote:
Very impressive, congratulations on solving this problem.


Thanks... I hate giving up. I'm really liking Slackware, too; reminds me a lot of Gentoo because it actually takes some knowledge to use it effectively. Oh, and it's slim and fast, even running KDE with the effects turned on.


However; viola should be "voilà".


Fixed. In my excitement, I quite possibly made the only spelling error I've ever made here. Smile




Edited by on 06-09-08 15:00