Follow us on Twitter!
It is the path of least resistance that makes rivers and men crooked. - Bj Palmer
Thursday, April 24, 2014
Navigation
Home
HellBoundHackers Main:
HellBoundHackers Find:
HellBoundHackers Information:
Learn
Communicate
Submit
Shop
Challenges
HellBoundHackers Exploit:
HellBoundHackers Programming:
HellBoundHackers Think:
HellBoundHackers Track:
HellBoundHackers Patch:
HellBoundHackers Other:
HellBoundHackers Need Help?
Other
Members Online
Total Online: 23
Guests Online: 22
Members Online: 1

Registered Members: 82904
Newest Member: jamessmith123
Latest Articles
View Thread

HellBound Hackers | HellBound Hackers | Questions

Author

Err, PHP 5.2.9-1 on IIS 5.1


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 23-03-09 02:08
I am not one to get stressed... It is very unhealthy. Not that I care about my health too much. Little do I care about, but I am in a aggravating situation. I am setting up a simple IIS server on a box of mine and well PHP will not cooperate with me whatsoever. I can install PHP, and the .php format will be there, I compiled a simple PHP file to display the info, just to let me know it works, shown in the following.
Code

<?php
phpInfo();
?>




When I run this from http://localhost, it will just ask me to open with or download, and when i open with the default option is "CLI", the PHP client, which doesn't preform any action.
I have tried older version, as far back as 5.0 and still, no luck.
Please assist me before I become disturbed. Yeah, I don't know.
Help would be appreciated. Installing to C:/PHP, on a SP3 box.
Author

RE: Err, PHP 5.2.9-1 on IIS 5.1

ynori7
Member



Posts: 1486
Location: #valhalla
Joined: 08.10.07
Rank:
God
Posted on 23-03-09 04:38
chronicburst wrote:
When I run this from http://localhost, it will just ask me to open with or download.

What exactly are you typing into your url bar?

Make sure your php file is in the htdocs directory, and type http://localhost/filename.php and it should work if you have it installed and configured right.


halls-of-valhalla.org/images/affiliateLogo.png voodoorage.halls-of-valhalla.org/images/smallLogo.png
i537.photobucket.com/albums/ff338/ynori77/archenemysig1.jpg
ynori7 http://halls-of-valhalla.org
Author

RE: Err, PHP 5.2.9-1 on IIS 5.1


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 23-03-09 04:43
ynori7 wrote:
it should work if you have it installed and configured right.

He probably hasn't.
http://www.iis-ai. . .eps?page=1
I know you've probably already seen an installation guide but people there are having the same problems, first comment deals with it, check out what they have to say.


Author

RE: Err, PHP 5.2.9-1 on IIS 5.1

SySTeM
Member

Your avatar

Posts: 1524
Location: England, UK
Joined: 27.07.05
Rank:
HBH Guru
Posted on 23-03-09 14:22
Why are you using IIS anyway?


img138.imageshack.us/img138/6527/sig2ak1.jpg
www.hellboundhackers.org/sig/r/2783.png

http://www.elites0ft.com/
Author

RE: Err, PHP 5.2.9-1 on IIS 5.1


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 23-03-09 21:42
I am using IIS while my 32 bit Fedora Core 10 finishes installing. I had an error with that as well, but I believe I accidently downloaded the 64bit version. Ill have to see. But I am doing IIS moreso to get a feel for it and I just want to make a vulnrable site to diminish. Don't ask why, couldn't tell ya. To learn.
As for putting the file in the right directory, I have.
Code
http://localhost/info.php
http://127.0.0.1/info.php
http://192.168.1.*/info.php




Just before we continue I thought it pertinent to mention that it if you have already installed, or attempted to install PHP on your system then you must remove all traces of that install before continuing. If ANY PHP files exist anywhere else on your system that are accessible via the PATH environment variable, then it is very possible (even probable if the previous version of PHP was different) that you will have issues with hosting PHP content.

I am left to believe that my problem is all of my attempts. I just redid the box.
Ill update/edit this.
Author

RE: Err, PHP 5.2.9-1 on IIS 5.1


Member

Your avatar

Posts:
Location:
Joined: 01.01.70
Rank:
Guest
Posted on 24-03-09 19:17
Oh, sorry for not updating. Thank you for your help, it is all good now. I forgot my ";" in my environment variables. Slipped my mind. Thank you.
If any of you have some useful articles on securing 5.1 IIS, that would be very nice if you could link-a-tize.